Wednesday, November 09, 2022

[Tested] Konfigurasi OSPF Single Area Di Router Cisco 7200 : Test Failed Over Link

Ini hanya sekedar sharing, soalnya daripada Youtube-an terus ... nulis di Blog kayanya lebih bermanfaat :D

#####
OSPF kepanjangan dari Open Shothest Path First adalah salah satu Routing protokol pada kebanyakan Router yang berfungsi untuk mendistribusikan informasi jaringan dari satu Router ke Router lainnya. Dengan menggunakan OSPF pada jaringan kita dapat mengaktifkan dynamic routing sehingga dalam konfigurasi routing tidak seribet Static Routing.

OSPF merupakan protokol IGP (Interior Gateway routing Protocol) yang artinya OSPF hanya dapat mendistribusikan informasi Routing dalam satu AS yang sama saja, setiap informasi routing dalam OSPF disebut dengan LSA (Link State Advertisement), sekumpulan LSA tersebut disimpan dalam LSDB (Link State Database) setiap Router.

Tools yang saya gunakan:
1. Aplikasi GNS3 (Karena Lebih Real Ketimbang Packet Tracert)
2. Cisco Router 7200
Cisco IOS Software, 7200 Software (C7200-ADVENTERPRISEK9-M)
Version 12.4(24)T5
3. Cisco 3600 (L3 & L2)
Cisco IOS Software, 3600 Software (C3660-A3JK9S-M)
This is a normal Router with a SW module inside (NM-16ESW)
Version 12.4(25d)

Topology yang saya buat, ada 4 Buah Router Cisco 7200 dan Switch L2-L3 Cisco 3600 untuk Test failed over Link

Konfigurasi di 4 Router Cisco 7200

Konfigurasi di Router 1 Cisco 7200
R1-Cisco7200#
interface GigabitEthernet0/0
 description TO-R2
 ip address 10.10.10.1 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet1/0
 description TO-L2-A
 no ip address
 negotiation auto
!
interface GigabitEthernet1/0.100
 description VLAN-100
 encapsulation dot1Q 100
 ip address 192.168.100.1 255.255.255.0
!
interface GigabitEthernet2/0
 description TO-R4
 ip address 30.30.30.1 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface GigabitEthernet2/0
 network 10.10.10.0 0.0.0.3 area 0
 network 30.30.30.0 0.0.0.3 area 0
 network 192.168.100.0 0.0.0.3 area 0
 network 192.168.200.0 0.0.0.3 area 0

R1-Cisco7200#show interfaces description
Interface                      Status         Protocol Description
Et0/0                          admin down     down
Gi0/0                          up             up       TO-R2
Gi1/0                          up             up       TO-L2-A
Gi1/0.100                      up             up       VLAN-100
Gi2/0                          up             up       TO-R4

R1-Cisco7200#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         10.10.10.1      YES NVRAM  up                    up
GigabitEthernet1/0         unassigned      YES NVRAM  up                    up
GigabitEthernet1/0.100     192.168.100.1   YES NVRAM  up                    up
GigabitEthernet2/0         30.30.30.1      YES NVRAM  up                    up

Cek Status OSFP-nya apakah Full atau tidak
R1-Cisco7200#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
50.50.50.2        0   FULL/  -        00:00:34    30.30.30.2      GigabitEthernet2/0
40.40.40.1        0   FULL/  -        00:00:39    10.10.10.2      GigabitEthernet0/0

Konfigurasi di Router 2 Cisco 7200
R2-Cisco7200#
interface GigabitEthernet0/0
 description TO-R1
 ip address 10.10.10.2 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet1/0
 description TO-R4
 ip address 40.40.40.1 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 negotiation auto
!
interface GigabitEthernet2/0
 description TO-R3
 ip address 20.20.20.1 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface GigabitEthernet1/0
 no passive-interface GigabitEthernet2/0
 network 10.10.10.0 0.0.0.3 area 0
 network 20.20.20.0 0.0.0.3 area 0
 network 40.40.40.0 0.0.0.3 area 0
!

R2-Cisco7200#show interfaces description
Interface                      Status         Protocol Description
Et0/0                          admin down     down
Gi0/0                          up             up       TO-R1
Gi1/0                          up             up       TO-R4
Gi2/0                          up             up       TO-R3

R2-Cisco7200#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         10.10.10.2      YES NVRAM  up                    up
GigabitEthernet1/0         40.40.40.1      YES NVRAM  up                    up
GigabitEthernet2/0         20.20.20.1      YES NVRAM  up                    up

Cek Status OSFP-nya apakah Full atau tidak
R2-Cisco7200#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
50.50.50.2        0   FULL/  -        00:00:37    40.40.40.2      GigabitEthernet1/0
192.168.200.1     0   FULL/  -        00:00:38    20.20.20.2      GigabitEthernet2/0
192.168.100.1     0   FULL/  -        00:00:37    10.10.10.1      GigabitEthernet0/0

Konfigurasi di Router 3 Cisco 7200
R3-Cisco7200#
interface GigabitEthernet0/0
 description TO-R2
 ip address 20.20.20.2 255.255.255.252
 ip ospf network point-to-point
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
interface GigabitEthernet1/0
 description TO-R4
 ip address 50.50.50.1 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 negotiation auto
!
interface GigabitEthernet2/0
 description TO-L2-B
 no ip address
 no ip redirects
 no ip unreachables
 negotiation auto
!
interface GigabitEthernet2/0.200
 description VLAN-200
 encapsulation dot1Q 200
 ip address 192.168.200.1 255.255.255.0
 no ip unreachables
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface GigabitEthernet1/0
 network 20.20.20.0 0.0.0.3 area 0
 network 50.50.50.0 0.0.0.3 area 0
 network 192.168.100.0 0.0.0.3 area 0
 network 192.168.200.0 0.0.0.3 area 0

R3-Cisco7200#show interfaces description
Interface                      Status         Protocol Description
Et0/0                          admin down     down
Gi0/0                          up             up       TO-R2
Gi1/0                          up             up       TO-R4
Gi2/0                          up             up       TO-L2-B
Gi2/0.200                      up             up       VLAN-200

R3-Cisco7200#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         20.20.20.2      YES NVRAM  up                    up
GigabitEthernet1/0         50.50.50.1      YES NVRAM  up                    up
GigabitEthernet2/0         unassigned      YES NVRAM  up                    up
GigabitEthernet2/0.200     192.168.200.1   YES NVRAM  up                    up

Cek Status OSFP-nya apakah Full atau tidak
R3-Cisco7200#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
50.50.50.2        0   FULL/  -        00:00:30    50.50.50.2      GigabitEthernet1/0
40.40.40.1        0   FULL/  -        00:00:31    20.20.20.1      GigabitEthernet0/0

Konfigurasi di Router 4 Cisco 7200
R4-Cisco7200#
interface GigabitEthernet0/0
 description TO-R2
 ip address 40.40.40.2 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
interface GigabitEthernet1/0
 description TO-R3
 ip address 50.50.50.2 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 negotiation auto
!
interface GigabitEthernet2/0
 description TO-R1
 ip address 30.30.30.2 255.255.255.252
 no ip redirects
 no ip unreachables
 ip ospf network point-to-point
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface GigabitEthernet1/0
 no passive-interface GigabitEthernet2/0
 network 30.30.30.0 0.0.0.3 area 0
 network 40.40.40.0 0.0.0.3 area 0
 network 50.50.50.0 0.0.0.3 area 0
!

R4-Cisco7200#show interfaces description
Interface                      Status         Protocol Description
Et0/0                          admin down     down
Gi0/0                          up             up       TO-R2
Gi1/0                          up             up       TO-R3
Gi2/0                          up             up       TO-R1

R4-Cisco7200#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         40.40.40.2      YES NVRAM  up                    up
GigabitEthernet1/0         50.50.50.2      YES NVRAM  up                    up
GigabitEthernet2/0         30.30.30.2      YES NVRAM  up                    up

Cek Status OSFP-nya apakah Full atau tidak
R4-Cisco7200#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.200.1     0   FULL/  -        00:00:35    50.50.50.1      GigabitEthernet1/0
40.40.40.1        0   FULL/  -        00:00:31    40.40.40.1      GigabitEthernet0/0
192.168.100.1     0   FULL/  -        00:00:39    30.30.30.1      GigabitEthernet2/0


Konfigurasi disisi Switch L2-L3 Cisco 3600 Untuk Test Link dengan IP Address:
Cisco3600-L2-A#show run interface vlan 100
Building configuration...
Current configuration : 65 bytes
!
interface Vlan100
 ip address 192.168.100.3 255.255.255.0
end

Cisco3600-L2-B#show run interface vlan 200
Building configuration...
Current configuration : 65 bytes
!
interface Vlan200
 ip address 192.168.200.3 255.255.255.0
end

Pengetesan di Switch dengan Traceroute yang telah dipasang Interface VLAN-100 dan Interface VLAN-200 dengan Semua Link UP

Pengetesan di Switch dengan Traceroute yang telah dipasang Interface VLAN-100 dan Interface VLAN-200 dengan Test Failed Over Link (Link ada yang down) dimana Hop yang dilewati hanya 2

Cisco3600-L2-A#traceroute 192.168.200.3 (Traceroute dari Router-1 ke arah Router-3 yang beda IP Network dan Vlan) 
Type escape sequence to abort.
Tracing the route to 192.168.200.3
  1 192.168.100.1 16 msec 20 msec 12 msec
  2 10.10.10.2 44 msec 28 msec 32 msec
  3 20.20.20.2 52 msec 40 msec 40 msec
  4 192.168.200.3 56 msec 56 msec 52 msec

Cisco3600-L2-B#traceroute 192.168.100.3
Type escape sequence to abort.
Tracing the route to 192.168.100.3
  1 192.168.200.1 4 msec 8 msec 12 msec
  2 20.20.20.1 20 msec 24 msec 28 msec
  3 10.10.10.1 40 msec 40 msec 48 msec
  4 192.168.100.3 52 msec 52 msec 48 msec
Pengetesan di Switch dengan Traceroute yang telah dipasang Interface VLAN-100 dan Interface VLAN-200 dengan Test Failed Over Link (Link ada yang down) dimana Hop yang dilewati menjadi 3

Dari Log yang ada ketika Link putus di Router 1 log-nya seperti ini:
R1-Cisco7200#
*Nov  9 06:59:05.495: %OSPF-5-ADJCHG: Process 1, Nbr 40.40.40.1 on GigabitEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

Status OSPF Yang Up hanya 1 sekarang (sebelumnya 2)
R1-Cisco7200#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
50.50.50.2        0   FULL/  -        00:00:32    30.30.30.2      GigabitEthernet2/0

Cisco3600-L2-A#traceroute 192.168.200.3
Type escape sequence to abort.
Tracing the route to 192.168.200.3
  1 192.168.100.1 12 msec 8 msec 12 msec
  2 30.30.30.2 28 msec 32 msec 28 msec
  3 40.40.40.1 52 msec 40 msec 40 msec
  4 20.20.20.2 48 msec 52 msec 48 msec
  5 192.168.200.3 100 msec 72 msec 60 msec

Dari Log yang ada ketika Link putus di Router 3 log-nya seperti ini:
R3-Cisco7200#
*Nov  9 06:59:01.611: %OSPF-5-ADJCHG: Process 1, Nbr 50.50.50.2 on GigabitEthernet1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

Status OSPF Yang Up hanya 1 sekarang (sebelumnya 2)
R3-Cisco7200#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
40.40.40.1        0   FULL/  -        00:00:35    20.20.20.1      GigabitEthernet0/0

Traceroute menjadi 3 Hop
Cisco3600-L2-B#traceroute 192.168.100.3
Type escape sequence to abort.
Tracing the route to 192.168.100.3
  1 192.168.200.1 12 msec 8 msec 12 msec
  2 20.20.20.1 20 msec 20 msec 24 msec
  3 40.40.40.2 48 msec 32 msec 28 msec
  4 30.30.30.1 56 msec 40 msec 40 msec
  5 192.168.100.3 60 msec 60 msec 64 msec

Temukan Artikel lainnya terkait Routing dan Switching di List All Articles Routing & Switching CIENA/CISCO/RAISECOM/BROCADE in This Blog [Updated]

Sunday, November 06, 2022

OSPF Problem Gak Mau FULL: Neighbor Down: Too many retransmissions

Dah berbulan-bulan gak Update Blog ... kita isi yah ^_^

#####
Ada kasus dimana OSPF di CISCO ASR903 dengan IOS-XE OSPF-nya gak mau FULL dan ini baru diketahui ketika Link Utama Down, Link Backup gak otomatis UP karena OSPF-nya problem

JKT-ASR903-1#show ip ospf neighbor
Neighbor ID Pri  State              Dead Time  Address       Interface
10.48.1.168  0     EXSTART/ - 00:00:38     10.49.4.57   TenGigabitEthernet0/0/2

Dari Log yang ada di JKT-ASR903-1 didapatkan seperti ini:
*Nov 5 15:00:01.676: %OSPF-5-ADJCHG: Process 1, Nbr 10.48.1.168 on TenGigabitEthernet0/0/2 from EXSTART to DOWN, Neighbor Down: Too many retransmissions
*Nov 5 15:01:01.674: %OSPF-5-ADJCHG: Process 1, Nbr 10.48.1.168 on TenGigabitEthernet0/0/2 from DOWN to DOWN, Neighbor Down: Ignore timer expired


Padahal OSPF di Interface CISCO ASR903 sudah diset MTU yang sama dengan Interface di perangkat lawannya yaitu Brocade CES yaitu 9126 tapi masih belum FULL juga (why ???)

Ternyata di Perangkat lawannya yang berbeda Merk yaitu Brocade CES ada settingan "ip global-mtu 9198" jadi walaupun di Interface diset MTU 9216 namun settingan Global-MTU di Brocade CES 9198 "mengalahkan" settingan MTU di Interface-nya

Sebelumnya saya coba delete dan create lagi MTU di Interface-nya trus juga nambahin "ip ospf mtu-ignore" sesuai hasil googling, ternyata gak ngaruh. yang berhasil adalah menambahkan ip mtu 9198 di Interface-nya. jadi di interface ada mtu 9216 dan ip mtu 9198

JKT-ASR903-1#show run interface tenGigabitEthernet 0/0/2
Building configuration...
Current configuration : 337 bytes
!
interface TenGigabitEthernet0/0/2
description TO-JKT-CES-2
mtu 9216
ip address 10.49.4.58 255.255.255.252
ip mtu 9198
ip ospf network point-to-point
ip ospf bfd
ip ospf 1 area 0
load-interval 30
carrier-delay up msec 10
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth
ip rsvp signalling hello graceful-restart
end

JKT-ASR903-1#show ip ospf neighbor
Neighbor ID Pri  State              Dead Time  Address       Interface
10.48.1.168  0     FULL/ -        00:00:38     10.49.4.57   TenGigabitEthernet0/0/2